Skip to content

← Actionable
High, CVSS 8.4amended

PraisonAI Vulnerable to RCE via Automatic tools.py Import

CVE-2026-40287GHSA-g985-wjh9-qxxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.5.140; praisonai 4.5.139), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-40287: 0.25% estimated exploitation activity in the next 30 days; percentile 15.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PraisonAI automatically imports ./tools.py from the current working directory when launching certain components. This includes call.py, toolresolver.py, and CLI tool-loading paths. A malicious tools.py placed in the process working directory is executed immediately, allowing arbitrary Python code execution in the host environment. Affected Code - call.py → importtoolsfromfile() - toolresolver.py → loadlocaltools() - tools.py → local tool import flow - PoC Create tools.py in the directory where PraisonAI is launched: Run any PraisonAI component that loads local tools, for example: Reproduction Steps 1. Create a malicious tools.py in the current working directory. 2. Start PraisonAI or invoke a CLI command that loads local tools. 3. Verify that /tmp/pwned.txt or the malicious command output exists. Impact An attacker who can place or influence tools.py in the working directory can execute arbitrary code in the PraisonAI process, compromising the host and any connected data. Reporter:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g985-wjh9-qxxc

  2. Revision 1 · created ·

    Published from osv record GHSA-g985-wjh9-qxxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40287

Advisory: PraisonAI Vulnerable to RCE via Automatic tools.py Import
IDs: CVE-2026-40287, GHSA-g985-wjh9-qxxc
Record: https://patchnext.com/advisories/cve-2026-40287 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.5.140; praisonai 4.5.139. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.5.139; fixed in 1.5.140
- PyPI praisonai: affected <= 4.5.138; fixed in 4.5.139

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents, praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g985-wjh9-qxxc (OSV record GHSA-g985-wjh9-qxxc lists affected ranges: PyPI praisonaiagents >=0 =0 <4.5.139 (fixed))
- Verified: https://github.com/advisories/GHSA-g985-wjh9-qxxc (GitHub-reviewed advisory GHSA-g985-wjh9-qxxc lists affected ranges: PyPI praisonaiagents >=0 =0 <=4.5.138)

Commands are suggestions: review each one before running it.

Loading voting…