Skip to content

← Actionable
Critical, CVSS 9.1amended

gramps-webapi: Zip Slip Path Traversal in Media Archive Import

CVE-2026-40258GHSA-m5gr-86j6-99jp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gramps-webapi 3.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-40258: 0.40% estimated exploitation activity in the next 30 days; percentile 34.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability (Zip Slip) exists in the media archive import feature. An authenticated user with owner-level privileges can craft a malicious ZIP file with directory-traversal filenames to write arbitrary files outside the intended temporary extraction directory on the server's local filesystem.

Details When importing media archives as ZIP file, `MediaImporter._check_disk_space_and_extract()` in `gramps_webapi/api/media_importer.py` called `zipfile.extractall()` without validating ZIP entry names. Python's `zipfile` module does not sanitize entry names containing `../` sequences, allowing extraction to paths outside the target directory. Only users with owner permission can upload media ZIP archives, so the biggest risk is for multi-tree deployments, where tree owners are distinct from server administrators. For multi-tree deployments, the impact depends on deployment configuration. Assuming the standard docker-based deployment is used: - **SQLite…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-m5gr-86j6-99jp

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-m5gr-86j6-99jp

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-m5gr-86j6-99jp

  4. Revision 2 · amended ·

    Amended from osv record GHSA-m5gr-86j6-99jp

  5. Revision 1 · created ·

    Published from ghsa record GHSA-m5gr-86j6-99jp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40258

Advisory: gramps-webapi: Zip Slip Path Traversal in Media Archive Import
IDs: CVE-2026-40258, GHSA-m5gr-86j6-99jp
Record: https://patchnext.com/advisories/cve-2026-40258 (revision 5, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gramps-webapi 3.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gramps-webapi: affected >= 1.6.0, < 3.11.1; fixed in 3.11.1

## Suggested inspection (read-only)
- `python -m pip show gramps-webapi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gramps-webapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m5gr-86j6-99jp (GitHub-reviewed advisory GHSA-m5gr-86j6-99jp lists affected ranges: PyPI gramps-webapi >=1.6.0 <=3.11.0)
- Verified: https://osv.dev/vulnerability/GHSA-m5gr-86j6-99jp (OSV record GHSA-m5gr-86j6-99jp lists affected ranges: PyPI gramps-webapi >=1.6.0 <3.11.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…