Incus Vulnerable to Panic via Snapshot Bounds Check
CVE-2026-40251GHSA-4m88-wxj4-9qj6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/lxc/incus/v6/cmd/incusd 7.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/lxc/incus/v6/cmd/incusd
- Affected
- < 7.0.0
- Fixed in
- 7.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4m88-wxj4-9qj6 lists affected ranges: Go github.com/lxc/incus/v6/cmd/incusd >=0 <7.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-40251: 0.41% estimated exploitation activity in the next 30 days; percentile 35.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Missing validation logic in the storage volume import logic allows an authenticated user with access to Incus' storage volume feature to cause the Incus daemon to crash. Repeated use of this issue can be used to keep Incus offline causing a denial of service. Details The backup restore subsystem contains an out-of-bounds panic vulnerability caused by an invalid bounds check when indexing snapshot metadata arrays. The same flawed pattern also appears in the migration path. When iterating through physical snapshots provided in a backup archive, the loop uses the index i to look up corresponding metadata in the parsed Config.Snapshots and Config.VolumeSnapshots slices. To ensure that the metadata slice is long enough, the code uses the guard condition len(slice) = i-1. This check is incorrect because it can still evaluate to true when the subsequent slice[i] access is out of bounds, including when i = len(slice), triggering a runtime panic. An attacker can trigger this by…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4m88-wxj4-9qj6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40251 Advisory: Incus Vulnerable to Panic via Snapshot Bounds Check IDs: CVE-2026-40251, GHSA-4m88-wxj4-9qj6 Record: https://patchnext.com/advisories/cve-2026-40251 (revision 1, source checked 26 Oct 2026, 15:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/lxc/incus/v6/cmd/incusd 7.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lxc/incus/v6/cmd/incusd: affected < 7.0.0; fixed in 7.0.0 ## Suggested inspection (read-only) - Go github.com/lxc/incus/v6/cmd/incusd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lxc/incus/v6/cmd/incusd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4m88-wxj4-9qj6 (GitHub-reviewed advisory GHSA-4m88-wxj4-9qj6 lists affected ranges: Go github.com/lxc/incus/v6/cmd/incusd >=0 <7.0.0) Commands are suggestions: review each one before running it.
Loading voting…