Skip to content

← Actionable
High, CVSS 7.4amended

OpenStack Cyborg uses rule:allow (check_str='@') as the default policy for multiple API endpoints

CVE-2026-40213GHSA-mm7j-mhhj-hj36

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openstack-cyborg 16.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2026-40213: 0.21% estimated exploitation activity in the next 30 days; percentile 10.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Cyborg before 16.0.1 uses rule:allow (checkstr='@') as the default policy for multiple API endpoints. This unconditionally authorizes any request carrying a valid Keystone token regardless of roles, project membership, or scope. An authenticated user with zero role assignments can complete various actions such as reprogramming FPGA bitstreams on arbitrary compute nodes via agent RPC.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mm7j-mhhj-hj36

  2. Revision 1 · created ·

    Published from osv record GHSA-mm7j-mhhj-hj36

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40213

Advisory: OpenStack Cyborg uses rule:allow (check_str='@') as the default policy for multiple API endpoints
IDs: CVE-2026-40213, GHSA-mm7j-mhhj-hj36
Record: https://patchnext.com/advisories/cve-2026-40213 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openstack-cyborg 16.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openstack-cyborg: affected < 16.0.1; fixed in 16.0.1

## Suggested inspection (read-only)
- `python -m pip show openstack-cyborg`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openstack-cyborg.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mm7j-mhhj-hj36 (OSV record GHSA-mm7j-mhhj-hj36 lists affected ranges: PyPI openstack-cyborg >=0 <16.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-mm7j-mhhj-hj36 (GitHub-reviewed advisory GHSA-mm7j-mhhj-hj36 lists affected ranges: PyPI openstack-cyborg >=0 <16.0.1)

Commands are suggestions: review each one before running it.

Loading voting…