Skip to content

← Actionable
Low, CVSS 3.7

phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()

CVE-2026-40194GHSA-r854-jrxh-36qx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.51, 2.0.53, 1.0.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpseclib/phpseclib

    Affected
    >= 2.0.0, < 2.0.53>= 3.0.0, < 3.0.51>= 0.1.1, < 1.0.28
    Fixed in
    2.0.53, 1.0.28, 3.0.51

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-40194: 0.36% estimated exploitation activity in the next 30 days; percentile 30.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

phpseclib SSH2: Variable-time comparison in HMAC verification Summary phpseclib\Net\SSH2::getbinarypacket() uses PHP's != operator to compare a received SSH packet HMAC against the locally computed HMAC. != on equal-length binary strings in PHP uses memcmp(), which short-circuits on the first differing byte. This is a real variable-time comparison (CWE-208), proven by scaling benchmarks. The finding is Low severity (defense-in-depth), not Critical. Practical exploitation over the network is prevented by SSH's disconnect-on-MAC-failure behavior combined with per-connection session keys. The fix is a one-liner: replace != with hashequals(), which the codebase already uses in 9 other places. - Target: phpseclib/phpseclib - File: phpseclib/Net/SSH2.php - Lines (master e819a163c): 3405 and 3410 - CWE: CWE-208 (Observable Timing Discrepancy) - CVSS v3.1: 3.7 — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N - Severity: Low (cryptographic hygiene / defense-in-depth) - Affected branches:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r854-jrxh-36qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40194

Advisory: phpseclib has a variable-time HMAC comparison in SSH2::get_binary_packet() using != instead of hash_equals()
IDs: CVE-2026-40194, GHSA-r854-jrxh-36qx
Record: https://patchnext.com/advisories/cve-2026-40194 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.51, 2.0.53, 1.0.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpseclib/phpseclib: affected >= 2.0.0, < 2.0.53; >= 3.0.0, < 3.0.51; >= 0.1.1, < 1.0.28; fixed in 2.0.53, 1.0.28, 3.0.51

## Suggested inspection (read-only)
- Packagist phpseclib/phpseclib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpseclib/phpseclib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r854-jrxh-36qx (GitHub-reviewed advisory GHSA-r854-jrxh-36qx lists affected ranges: Packagist phpseclib/phpseclib >=2.0.0 =3.0.0 =0.1.1 <1.0.28)

Commands are suggestions: review each one before running it.

Loading voting…