Skip to content

← Actionable
High, CVSS 8.2

Maddy Mail Server has an LDAP Filter Injection via Unsanitized Username

CVE-2026-40193GHSA-5835-4gvc-32pc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/foxcpp/maddy 0.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-40193: 0.42% estimated exploitation activity in the next 30 days; percentile 36.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The auth.ldap module constructs LDAP search filters and DN strings by directly interpolating user-supplied usernames via strings.ReplaceAll() without any LDAP filter escaping. An attacker who can reach the SMTP submission (AUTH PLAIN) or IMAP LOGIN interface can inject arbitrary LDAP filter expressions through the username field, enabling identity spoofing, LDAP directory enumeration, and attribute value extraction. The go-ldap/ldap/v3 library—already imported in the same file—provides ldap.EscapeFilter() specifically for this purpose, but it is never called. Patched version Upgrade to maddy 0.9.3. Details Affected file: internal/auth/ldap/ldap.go Three locations substitute the raw, attacker-controlled username into LDAP filter or DN strings with no escaping: 1. Lookup() — line 228 (filter injection) 2. AuthPlain() — line 255 (DN template injection) 3. AuthPlain() — line 260 (filter injection) The go-ldap/ldap/v3 library (v3.4.10, imported at line 17) provides…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5835-4gvc-32pc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40193

Advisory: Maddy Mail Server has an LDAP Filter Injection via Unsanitized Username
IDs: CVE-2026-40193, GHSA-5835-4gvc-32pc
Record: https://patchnext.com/advisories/cve-2026-40193 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/foxcpp/maddy 0.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/foxcpp/maddy: affected < 0.9.3; fixed in 0.9.3

## Suggested inspection (read-only)
- Go github.com/foxcpp/maddy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/foxcpp/maddy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5835-4gvc-32pc (GitHub-reviewed advisory GHSA-5835-4gvc-32pc lists affected ranges: Go github.com/foxcpp/maddy >=0 <0.9.3)

Commands are suggestions: review each one before running it.

Loading voting…