Skip to content

← Actionable
Medium, CVSS 6.1amended

sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements

CVE-2026-40186GHSA-9mrh-v2v3-xpfm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize-html 2.17.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-40186: 0.25% estimated exploitation activity in the next 30 days; percentile 16.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Commit 49d0bb7 introduced a regression in sanitize-html that bypasses allowedTags enforcement for text inside nonTextTagsArray elements (textarea and option). Entity-encoded HTML inside these elements passes through the sanitizer as decoded, unescaped HTML, allowing injection of arbitrary tags including XSS payloads. This affects any application using sanitize-html that includes option or textarea in its allowedTags configuration. Details The vulnerable code is at packages/sanitize-html/index.js:569-573: The comment is factually incorrect. htmlparser2 10.x does decode HTML entities inside both <textarea and <option elements before passing text to the ontext callback. This can be verified: Because the code assumes the text is "already properly encoded" and skips escapeHtml(), the decoded entities (<, ) are written directly to the output as literal HTML characters. This completely bypasses the allowedTags filter — any tag can be injected inside an allowed option or textarea…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9mrh-v2v3-xpfm

  2. Revision 1 · created ·

    Published from osv record GHSA-9mrh-v2v3-xpfm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40186

Advisory: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements
IDs: CVE-2026-40186, GHSA-9mrh-v2v3-xpfm
Record: https://patchnext.com/advisories/cve-2026-40186 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sanitize-html 2.17.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sanitize-html: affected >= 2.17.2, < 2.17.3; fixed in 2.17.3

## Suggested inspection (read-only)
- `npm ls sanitize-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sanitize-html.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9mrh-v2v3-xpfm (OSV record GHSA-9mrh-v2v3-xpfm lists affected ranges: npm sanitize-html >=2.17.2 <2.17.3 (fixed))
- Verified: https://github.com/advisories/GHSA-9mrh-v2v3-xpfm (GitHub-reviewed advisory GHSA-9mrh-v2v3-xpfm lists affected ranges: npm sanitize-html >=2.17.2 <2.17.3)

Commands are suggestions: review each one before running it.

Loading voting…