Skip to content

← Actionable
High, CVSS 7.1amended

Bugsink affected by authenticated arbitrary file write in artifactbundle/assemble

CVE-2026-40162GHSA-8hw4-fhww-273g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bugsink 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bugsink

    Affected
    >= 2.1.0, <= 2.1.0
    Fixed in
    2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-40162: 0.30% estimated exploitation activity in the next 30 days; percentile 22.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Authenticated arbitrary file write in artifact bundle assembly Summary An authenticated file write vulnerability was identified in Bugsink 2.1.0 in the artifact bundle assembly flow. A user with a valid authentication token could cause the application to write attacker-controlled content to a filesystem location writable by the Bugsink process. This issue requires authentication and affects only version 2.1.0. The issue is fixed in 2.1.1. Impact This vulnerability allows an authenticated user to create or overwrite files within locations writable by the Bugsink service account. The practical impact depends on the deployment environment and filesystem permissions of the running process. Possible consequences include: modification of application data files corruption of uploaded assets or temporary files overwriting files in mounted writable volumes disruption of normal application behavior No unauthenticated exploitation is known. No direct code execution has been demonstrated as part…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8hw4-fhww-273g

  2. Revision 1 · created ·

    Published from osv record GHSA-8hw4-fhww-273g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40162

Advisory: Bugsink affected by authenticated arbitrary file write in artifactbundle/assemble
IDs: CVE-2026-40162, GHSA-8hw4-fhww-273g
Record: https://patchnext.com/advisories/cve-2026-40162 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bugsink 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bugsink: affected >= 2.1.0, <= 2.1.0; fixed in 2.1.1

## Suggested inspection (read-only)
- `python -m pip show bugsink`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bugsink.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8hw4-fhww-273g (OSV record GHSA-8hw4-fhww-273g lists affected ranges: PyPI bugsink >=2.1.0 <2.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8hw4-fhww-273g (GitHub-reviewed advisory GHSA-8hw4-fhww-273g lists affected ranges: PyPI bugsink >=2.1.0 <=2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…