Skip to content

← Actionable
Critical, CVSS 9.4amended

PraisonAI vulnerable to arbitrary file write via path traversal in praisonai recipe unpack

CVE-2026-40157GHSA-99g3-w8gr-x37c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    >= 2.7.2, < 4.5.128
    Fixed in
    4.5.128

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-40157: 0.38% estimated exploitation activity in the next 30 days; percentile 31.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

| Field | Value | |---|---| | Severity | Critical | | Type | Path traversal -- arbitrary file write via tar.extract() without member validation | | Affected | src/praisonai/praisonai/cli/features/recipe.py:1170-1172 | Summary cmdunpack in the recipe CLI extracts .praison tar archives using raw tar.extract() without validating archive member paths. A .praison bundle containing ../../ entries will write files outside the intended output directory. An attacker who distributes a malicious bundle can overwrite arbitrary files on the victim's filesystem when they run praisonai recipe unpack. Details The vulnerable code is in cli/features/recipe.py:1170-1172: The only check is whether the member is manifest.json. The code never validates member names -- absolute paths, .. components, and symlinks all pass through. Python's tarfile.extract() resolves these relative to the destination, so a member named ../../.bashrc lands two directories above recipedir. The codebase does contain a safe…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-99g3-w8gr-x37c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-99g3-w8gr-x37c

  4. Revision 1 · created ·

    Published from ghsa record GHSA-99g3-w8gr-x37c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40157

Advisory: PraisonAI vulnerable to arbitrary file write via path traversal in `praisonai recipe unpack`
IDs: CVE-2026-40157, GHSA-99g3-w8gr-x37c
Record: https://patchnext.com/advisories/cve-2026-40157 (revision 4, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected >= 2.7.2, < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-99g3-w8gr-x37c (GitHub-reviewed advisory GHSA-99g3-w8gr-x37c lists affected ranges: PyPI praisonai >=2.7.2 <4.5.128)
- Verified: https://osv.dev/vulnerability/GHSA-99g3-w8gr-x37c (OSV record GHSA-99g3-w8gr-x37c lists affected ranges: PyPI praisonai >=2.7.2 <4.5.128 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…