Auth0 Next.js SDK has Improper Proxy Cache Lookup
CVE-2026-40155GHSA-xq8m-7c5p-c2r6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@auth0/nextjs-auth0 4.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.12.0, <= 4.17.0
- Fixed in
- 4.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xq8m-7c5p-c2r6 lists affected ranges: npm @auth0/nextjs-auth0 >=4.12.0 <4.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq8m-7c5p-c2r6 lists affected ranges: npm @auth0/nextjs-auth0 >=4.12.0 <=4.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-40155: 0.21% estimated exploitation activity in the next 30 days; percentile 11.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description In affected versions of the Next.js SDK, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Which Projects are Affected? Users are affected if they meet all of the following preconditions: - Applications using the auth0/nextjs-auth0 SDK, versions 4.12.0 to 4.17.0, and - Applications using the proxy handler /me/ and /my-org/ with DPoP enabled. Affected product and versions Auth0/nextjs-auth0 v4.12.0 to 4.17.0 Resolution Upgrade Auth0/nextjs-auth0 version to v4.18.0 or greater Acknowledgements Okta would like to thank Reynaldo Immanuel for their discovery and responsible disclosure.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xq8m-7c5p-c2r6
- Revision 1 · created ·
Published from osv record GHSA-xq8m-7c5p-c2r6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40155 Advisory: Auth0 Next.js SDK has Improper Proxy Cache Lookup IDs: CVE-2026-40155, GHSA-xq8m-7c5p-c2r6 Record: https://patchnext.com/advisories/cve-2026-40155 (revision 2, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @auth0/nextjs-auth0 4.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @auth0/nextjs-auth0: affected >= 4.12.0, <= 4.17.0; fixed in 4.18.0 ## Suggested inspection (read-only) - `npm ls @auth0/nextjs-auth0 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @auth0/nextjs-auth0. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xq8m-7c5p-c2r6 (OSV record GHSA-xq8m-7c5p-c2r6 lists affected ranges: npm @auth0/nextjs-auth0 >=4.12.0 <4.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xq8m-7c5p-c2r6 (GitHub-reviewed advisory GHSA-xq8m-7c5p-c2r6 lists affected ranges: npm @auth0/nextjs-auth0 >=4.12.0 <=4.17.0) Commands are suggestions: review each one before running it.
Loading voting…