Skip to content

← Actionable
Critical, CVSS 9.3amended

PraisonAI Vulnerable Untrusted Remote Template Code Execution

CVE-2026-40154GHSA-pv9q-275h-rh7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    < 4.5.128
    Fixed in
    4.5.128

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-40154: 0.30% estimated exploitation activity in the next 30 days; percentile 23.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PraisonAI treats remotely fetched template files as trusted executable code without integrity verification, origin validation, or user confirmation, enabling supply chain attacks through malicious templates. --- Description When a user installs a template from a remote source (e.g., GitHub), PraisonAI downloads Python files (including tools.py) to a local cache without: 1. Code signing verification 2. Integrity checksum validation 3. Dangerous code pattern scanning 4. User confirmation before execution When the template is subsequently used, the cached tools.py is automatically loaded and executed via execmodule(), granting the template's code full access to the user's environment, filesystem, and network. --- Affected Code Template download (no verification): Automatic execution (no confirmation): --- Trust Boundary Violation PraisonAI breaks the expected security boundary between: - Data: Template metadata, YAML configuration (should be safe to load) - Code: Python files from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pv9q-275h-rh7x

  2. Revision 2 · amended ·

    Amended from osv record GHSA-pv9q-275h-rh7x

  3. Revision 1 · created ·

    Published from ghsa record GHSA-pv9q-275h-rh7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40154

Advisory: PraisonAI Vulnerable Untrusted Remote Template Code Execution
IDs: CVE-2026-40154, GHSA-pv9q-275h-rh7x
Record: https://patchnext.com/advisories/cve-2026-40154 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pv9q-275h-rh7x (GitHub-reviewed advisory GHSA-pv9q-275h-rh7x lists affected ranges: PyPI praisonai >=0 <4.5.128)
- Verified: https://osv.dev/vulnerability/GHSA-pv9q-275h-rh7x (OSV record GHSA-pv9q-275h-rh7x lists affected ranges: PyPI praisonai >=0 <4.5.128 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…