Skip to content

← Actionable
High, CVSS 7.4amended

PraisonAIAgents: Environment Variable Secret Exfiltration via os.path.expandvars() Bypassing shell=False in Shell Tool

CVE-2026-40153GHSA-v8g7-9q6v-p3x8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-40153: 0.27% estimated exploitation activity in the next 30 days; percentile 19.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The executecommand function in shelltools.py calls os.path.expandvars() on every command argument at line 64, manually re-implementing shell-level environment variable expansion despite using shell=False (line 88) for security. This allows exfiltration of secrets stored in environment variables (database credentials, API keys, cloud access keys). The approval system displays the unexpanded $VAR references to human reviewers, creating a deceptive approval where the displayed command differs from what actually executes. Details The vulnerable code is in src/praisonai-agents/praisonaiagents/tools/shelltools.py: The security problem is a disconnect between the approval display and actual execution: 1. The LLM generates a tool call: executecommand(command="cat $DATABASEURL") 2. checktoolapprovalsync in toolexecution.py:558 passes {"command": "cat $DATABASEURL"} to the approval backend 3. ConsoleBackend (backends.py:81-85) displays command: cat $DATABASEURL — the literal…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v8g7-9q6v-p3x8

  2. Revision 1 · created ·

    Published from osv record GHSA-v8g7-9q6v-p3x8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40153

Advisory: PraisonAIAgents: Environment Variable Secret Exfiltration via os.path.expandvars() Bypassing shell=False in Shell Tool
IDs: CVE-2026-40153, GHSA-v8g7-9q6v-p3x8
Record: https://patchnext.com/advisories/cve-2026-40153 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected < 1.5.128; fixed in 1.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v8g7-9q6v-p3x8 (OSV record GHSA-v8g7-9q6v-p3x8 lists affected ranges: PyPI praisonaiagents >=0 <1.5.128 (fixed))
- Verified: https://github.com/advisories/GHSA-v8g7-9q6v-p3x8 (GitHub-reviewed advisory GHSA-v8g7-9q6v-p3x8 lists affected ranges: PyPI praisonaiagents >=0 <1.5.128)

Commands are suggestions: review each one before running it.

Loading voting…