Skip to content

← Actionable
High, CVSS 7.9amended

PraisonAI: Unauthenticated Allow-List Manipulation Bypasses Agent Tool Approval Safety Controls

CVE-2026-40149GHSA-4wr3-f4p3-5wjh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    < 4.5.128
    Fixed in
    4.5.128

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.9 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-40149: 0.23% estimated exploitation activity in the next 30 days; percentile 13.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The gateway's /api/approval/allow-list endpoint permits unauthenticated modification of the tool approval allowlist when no authtoken is configured (the default). By adding dangerous tool names (e.g., shellexec, filewrite) to the allowlist, an attacker can cause the ExecApprovalManager to auto-approve all future agent invocations of those tools, bypassing the human-in-the-loop safety mechanism that the approval system is specifically designed to enforce. Details The vulnerability arises from the interaction of three components: 1. Authentication bypass in default config checkauth() in server.py:243-246 returns None (no error) when self.config.authtoken is falsy: GatewayConfig defaults authtoken to None (config.py:61): 2. Unrestricted allowlist modification The approvalallowlist handler at server.py:381-420 calls checkauth() and proceeds when it returns None: There is no validation that toolname corresponds to a real tool, no restriction on which tools can be allowlisted, and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4wr3-f4p3-5wjh

  2. Revision 1 · created ·

    Published from osv record GHSA-4wr3-f4p3-5wjh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40149

Advisory: PraisonAI: Unauthenticated Allow-List Manipulation Bypasses Agent Tool Approval Safety Controls
IDs: CVE-2026-40149, GHSA-4wr3-f4p3-5wjh
Record: https://patchnext.com/advisories/cve-2026-40149 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4wr3-f4p3-5wjh (OSV record GHSA-4wr3-f4p3-5wjh lists affected ranges: PyPI praisonai >=0 <4.5.128 (fixed))
- Verified: https://github.com/advisories/GHSA-4wr3-f4p3-5wjh (GitHub-reviewed advisory GHSA-4wr3-f4p3-5wjh lists affected ranges: PyPI praisonai >=0 <4.5.128)

Commands are suggestions: review each one before running it.

Loading voting…