Skip to content

← Actionable
Medium, CVSS 6.5amended

PraisonAI Vulnerable to Decompression Bomb DoS via Recipe Bundle Extraction Without Size Limits

CVE-2026-40148GHSA-f2h6-7xfr-xm8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    < 4.5.128
    Fixed in
    4.5.128

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40148: 0.24% estimated exploitation activity in the next 30 days; percentile 15.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The safeextractall() function in PraisonAI's recipe registry validates archive members against path traversal attacks but performs no checks on individual member sizes, cumulative extracted size, or member count before calling tar.extractall(). An attacker can publish a malicious recipe bundle containing highly compressible data (e.g., 10GB of zeros compressing to ~10MB) that exhausts the victim's disk when pulled via LocalRegistry.pull() or HttpRegistry.pull(). Details The vulnerable function is safeextractall() at src/praisonai/praisonai/recipe/registry.py:131-162: The function iterates all tar members and checks for path traversal (absolute paths, .. components, resolved path escaping), but never inspects member.size. The TarInfo.size attribute is available on every member and represents the uncompressed size, but it is never read. This function is called from two locations: - LocalRegistry.pull() at line 396-397 - HttpRegistry.pull() at line 791-792 The publish() method…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2h6-7xfr-xm8w

  2. Revision 1 · created ·

    Published from osv record GHSA-f2h6-7xfr-xm8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40148

Advisory: PraisonAI Vulnerable to Decompression Bomb DoS via Recipe Bundle Extraction Without Size Limits
IDs: CVE-2026-40148, GHSA-f2h6-7xfr-xm8w
Record: https://patchnext.com/advisories/cve-2026-40148 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f2h6-7xfr-xm8w (OSV record GHSA-f2h6-7xfr-xm8w lists affected ranges: PyPI praisonai >=0 <4.5.128 (fixed))
- Verified: https://github.com/advisories/GHSA-f2h6-7xfr-xm8w (GitHub-reviewed advisory GHSA-f2h6-7xfr-xm8w lists affected ranges: PyPI praisonai >=0 <4.5.128)

Commands are suggestions: review each one before running it.

Loading voting…