Skip to content

← Actionable
High, CVSS 8.4amended

PraisonAI Vulnerable to Argument Injection into Cloud Run Environment Variables via Unsanitized Comma in gcloud --set-env-vars

CVE-2026-40113GHSA-fvxx-ggmx-3cjg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.128), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    < 4.5.128
    Fixed in
    4.5.128

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-40113: 0.23% estimated exploitation activity in the next 30 days; percentile 14.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary deploy.py constructs a single comma-delimited string for the gcloud run deploy --set-env-vars argument by directly interpolating openaimodel, openaikey, and openaibase without validating that these values do not contain commas. gcloud uses a comma as the key-value pair separator for --set-env-vars. A comma in any of the three values causes gcloud to parse the trailing text as additional KEY=VALUE definitions, injecting arbitrary environment variables into the deployed Cloud Run service. Grep Commands and Evidence Step 1. Confirm the vulnerable string construction at line 150 Expected output showing unsanitized interpolation: 150: '--set-env-vars', f'OPENAIMODELNAME={openaimodel},OPENAIAPIKEY={openaikey},OPENAIAPIBASE={openaibase}' Step 2. Confirm no comma validation exists before this line Expected output: no results related to input validation Step 3. View the full context of the vulnerable construction This block shows the gcloud command list where the three values are…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fvxx-ggmx-3cjg

  2. Revision 1 · created ·

    Published from osv record GHSA-fvxx-ggmx-3cjg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40113

Advisory: PraisonAI Vulnerable to Argument Injection into Cloud Run Environment Variables via Unsanitized Comma in gcloud --set-env-vars
IDs: CVE-2026-40113, GHSA-fvxx-ggmx-3cjg
Record: https://patchnext.com/advisories/cve-2026-40113 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.128. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.5.128; fixed in 4.5.128

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fvxx-ggmx-3cjg (OSV record GHSA-fvxx-ggmx-3cjg lists affected ranges: PyPI praisonai >=0 <4.5.128 (fixed))
- Verified: https://github.com/advisories/GHSA-fvxx-ggmx-3cjg (GitHub-reviewed advisory GHSA-fvxx-ggmx-3cjg lists affected ranges: PyPI praisonai >=0 <4.5.128)

Commands are suggestions: review each one before running it.

Loading voting…