Skip to content

← Actionable
High, CVSS 7.6amended

Jupyter Server has a CORS Origin Validation Bypass via re.match() in allow_origin_pat

CVE-2026-40110GHSA-24qx-w28j-9m6p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-40110: 0.31% estimated exploitation activity in the next 30 days; percentile 24.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jupyter Server uses re.match() to validate the Origin header against the alloworiginpat configuration. Since re.match() only anchors at the start of the string, an attacker who controls a domain like http://trusted.example.com.evil.com/ passes validation against a pattern intended to match only trusted.example.com. Impact <=2.17.0 Patches 057869a327c46730afede3eab0ca2d2e3e74acea, 49b34392feaa97735b3b777e3baf8f22f2a14ed8 Workarounds Wrap your alloworiginpat value with ^ and $ References https://github.com/jupyter-server/jupyterserver/pull/603 https://docs.python.org/3/library/re.html#re.fullmatch https://docs.python.org/3/library/re.html#re.match

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-24qx-w28j-9m6p

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-24qx-w28j-9m6p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40110

Advisory: Jupyter Server has a CORS Origin Validation Bypass via `re.match()` in `allow_origin_pat`
IDs: CVE-2026-40110, GHSA-24qx-w28j-9m6p
Record: https://patchnext.com/advisories/cve-2026-40110 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-server: affected <= 2.17.0; fixed in 2.18.0

## Suggested inspection (read-only)
- `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-24qx-w28j-9m6p (OSV record GHSA-24qx-w28j-9m6p lists affected ranges: PyPI jupyter-server >=0 <2.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-24qx-w28j-9m6p (GitHub-reviewed advisory GHSA-24qx-w28j-9m6p lists affected ranges: PyPI jupyter-server >=0 <=2.17.0)

Commands are suggestions: review each one before running it.

Loading voting…