Skip to content

← Actionable
Medium, CVSS 5.3

OpenMage LTS: Cross-user wishlist import leads to private option & file disclosure

CVE-2026-40098GHSA-665x-ppc4-685w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-40098: 0.18% estimated exploitation activity in the next 30 days; percentile 7.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-user wishlist item import via shared wishlist code, leading to private option disclosure and file-disclosure variant Summary The shared wishlist add-to-cart endpoint authorizes access with a public sharingcode, but loads the acted-on wishlist item by a separate global wishlistitemid and never verifies that the item belongs to the shared wishlist referenced by that code. This lets an attacker use: - a valid shared wishlist code for wishlist A - a wishlist item ID belonging to victim wishlist B to import victim item B into the attacker's cart through the shared wishlist flow for wishlist A. Because the victim item's stored buyRequest is reused during cart import, the victim's private custom-option data is copied into the attacker's quote. If the product uses a file custom option, this can be elevated to cross-user file disclosure because the imported file metadata is preserved and the download endpoint is not ownership-bound. Vulnerability Type - Broken object-level authorization…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-665x-ppc4-685w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40098

Advisory: OpenMage LTS: Cross-user wishlist import leads to private option & file disclosure
IDs: CVE-2026-40098, GHSA-665x-ppc4-685w
Record: https://patchnext.com/advisories/cve-2026-40098 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist openmage/magento-lts: affected < 20.17.0; fixed in 20.17.0

## Suggested inspection (read-only)
- Packagist openmage/magento-lts: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openmage/magento-lts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-665x-ppc4-685w (GitHub-reviewed advisory GHSA-665x-ppc4-685w lists affected ranges: Packagist openmage/magento-lts >=0 <20.17.0)

Commands are suggestions: review each one before running it.

Loading voting…