Skip to content

← Actionable
Low, CVSS 3.7

Step CA affected by an index out of bounds panic in TPM attestation EKU validation

CVE-2026-40097GHSA-9qq8-cgcv-qmc9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/smallstep/certificates 0.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-40097: 0.18% estimated exploitation activity in the next 30 days; percentile 7.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An attacker can trigger an index out-of-bounds panic in Step CA by sending a crafted attestation key (AK) certificate with an empty Extended Key Usage (EKU) extension during TPM device attestation. Details When processing a device-attest-01 ACME challenge using TPM attestation, Step CA validates that the AK certificate contains the tcg-kp-AIKCertificate Extended Key Usage OID. During this validation, the EKU extension value is decoded from its ASN.1 representation and the first element is checked. A crafted certificate could include an EKU extension that decodes to an empty sequence, causing the code to panic when accessing the first element of the empty slice. This vulnerability is only reachable when a device-attest-01 ACME challenge with TPM attestation is configured. Deployments not using TPM device attestation are not affected. Mitigations If you are unable to upgrade to v0.30.0 or newer, the attack can be mitigated by disabling or removing any ACME provisioners that use…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9qq8-cgcv-qmc9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40097

Advisory: Step CA affected by an index out of bounds panic in TPM attestation EKU validation
IDs: CVE-2026-40097, GHSA-9qq8-cgcv-qmc9
Record: https://patchnext.com/advisories/cve-2026-40097 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/smallstep/certificates 0.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/smallstep/certificates: affected >= 0.24.0, < 0.30.0; fixed in 0.30.0

## Suggested inspection (read-only)
- Go github.com/smallstep/certificates: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/smallstep/certificates.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9qq8-cgcv-qmc9 (GitHub-reviewed advisory GHSA-9qq8-cgcv-qmc9 lists affected ranges: Go github.com/smallstep/certificates >=0.24.0 <0.30.0)

Commands are suggestions: review each one before running it.

Loading voting…