Skip to content

← Actionable
Critical, CVSS 9.6amended

PraisonAI Vulnerable to OS Command Injection

CVE-2026-40088GHSA-2763-cj5r-c79m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.121), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI praisonai

    Affected
    < 4.5.121
    Fixed in
    4.5.121

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-40088: 0.42% estimated exploitation activity in the next 30 days; percentile 36.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The executecommand function and workflow shell execution are exposed to user-controlled input via agent workflows, YAML definitions, and LLM-generated tool calls, allowing attackers to inject arbitrary shell commands through shell metacharacters. --- Description PraisonAI's workflow system and command execution tools pass user-controlled input directly to subprocess.run() with shell=True, enabling command injection attacks. Input sources include: 1. YAML workflow step definitions 2. Agent configuration files (agents.yaml) 3. LLM-generated tool call parameters 4. Recipe step configurations The shell=True parameter causes the shell to interpret metacharacters (;, |, &&, $(), etc.), allowing attackers to execute arbitrary commands beyond the intended operation. --- Affected Code Primary command execution (shell=True default): Workflow shell step execution: Action orchestrator shell execution: --- Input Paths to Vulnerable Code Path 1: YAML Workflow Definition Users define workflows in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2763-cj5r-c79m

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2763-cj5r-c79m

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2763-cj5r-c79m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40088

Advisory: PraisonAI Vulnerable to OS Command Injection
IDs: CVE-2026-40088, GHSA-2763-cj5r-c79m
Record: https://patchnext.com/advisories/cve-2026-40088 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.121. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonai: affected < 4.5.121; fixed in 4.5.121

## Suggested inspection (read-only)
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2763-cj5r-c79m (GitHub-reviewed advisory GHSA-2763-cj5r-c79m lists affected ranges: PyPI praisonai >=0 <4.5.121)
- Verified: https://osv.dev/vulnerability/GHSA-2763-cj5r-c79m (OSV record GHSA-2763-cj5r-c79m lists affected ranges: PyPI praisonai >=0 <4.5.121 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…