LangChain has incomplete f-string validation in prompt templates
CVE-2026-40087GHSA-926x-3r5x-gfhw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-core 1.2.28, 0.3.84), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langchain-core
- Affected
- < 0.3.84>= 1.0.0a1, < 1.2.28
- Fixed in
- 0.3.84, 1.2.28
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-926x-3r5x-gfhw lists affected ranges: PyPI langchain-core >=0 =1.0.0a1 <1.2.28 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-40087: 0.26% estimated exploitation activity in the next 30 days; percentile 18.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
LangChain's f-string prompt-template validation was incomplete in two respects. First, some prompt template classes accepted f-string templates and formatted them without enforcing the same attribute-access validation as `PromptTemplate`. In particular, `DictPromptTemplate` and `ImagePromptTemplate` could accept templates containing attribute access or indexing expressions and subsequently evaluate those expressions during formatting. Examples of the affected shape include: ```python "{message.additional_kwargs[secret]}" "https://example.com/{image.class.name}.png" ``` Second, f-string validation based on parsed top-level field names did not reject nested replacement fields inside format specifiers. For example: ```python "{name:{name.class.name}}" ``` In this pattern, the nested replacement field appears in the format specifier rather than in the top-level field name. As a result, earlier validation based on parsed field names did not reject the template even though…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-926x-3r5x-gfhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40087 Advisory: LangChain has incomplete f-string validation in prompt templates IDs: CVE-2026-40087, GHSA-926x-3r5x-gfhw Record: https://patchnext.com/advisories/cve-2026-40087 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langchain-core 1.2.28, 0.3.84. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langchain-core: affected < 0.3.84; >= 1.0.0a1, < 1.2.28; fixed in 0.3.84, 1.2.28 ## Suggested inspection (read-only) - `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langchain-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-926x-3r5x-gfhw (OSV record GHSA-926x-3r5x-gfhw lists affected ranges: PyPI langchain-core >=0 =1.0.0a1 <1.2.28 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…