Skip to content

← Actionable
Low, CVSS 3.5

Beszel has an IDOR in hub API endpoints that read system ID from URL parameter

CVE-2026-40077GHSA-5f5r-95pg-xrpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/henrygd/beszel 0.18.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-40077: 0.22% estimated exploitation activity in the next 30 days; percentile 12.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Some API endpoints in the Beszel hub accept a user-supplied system ID and proceed without further checks that the user should have access to that system. As a result, any authenticated user can access these routes for any system if they know the system's ID. System IDs are random 15 character alphanumeric strings, and are not exposed to all users. However, it is theoretically possible for an authenticated user to enumerate a valid system ID via web API. To use the containers endpoints, the user would also need to enumerate a container ID, which is 12 digit hexadecimal string. Affected Component - File: internal/hub/api.go, lines 283–361 - Endpoints: - GET /api/beszel/containers/logs?system=SYSTEMID&container=CONTAINERID - GET /api/beszel/containers/info?system=SYSTEMID&container=CONTAINERID - GET /api/beszel/systemd/info?system=SYSTEMID&service=SERVICENAME - POST /api/beszel/smart/refresh?system=SYSTEMID - Commit: c7261b56f1bfb9ae57ef0856a0052cabb2fd3b84 Vulnerable Code The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5f5r-95pg-xrpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40077

Advisory: Beszel has an IDOR in hub API endpoints that read system ID from URL parameter
IDs: CVE-2026-40077, GHSA-5f5r-95pg-xrpm
Record: https://patchnext.com/advisories/cve-2026-40077 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/henrygd/beszel 0.18.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/henrygd/beszel: affected <= 0.18.6; fixed in 0.18.7

## Suggested inspection (read-only)
- Go github.com/henrygd/beszel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/henrygd/beszel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5f5r-95pg-xrpm (GitHub-reviewed advisory GHSA-5f5r-95pg-xrpm lists affected ranges: Go github.com/henrygd/beszel >=0 <=0.18.6)

Commands are suggestions: review each one before running it.

Loading voting…