Skip to content

← Actionable
High, CVSS 8.2amended

@sveltejs/adapter-node has a BODY_SIZE_LIMIT bypass

CVE-2026-40073GHSA-2crg-3p73-43xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 2.57.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-40073: 0.54% estimated exploitation activity in the next 30 days; percentile 45.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Under certain circumstances, requests could bypass the BODYSIZELIMIT on SvelteKit applications running with adapter-node. This bypass does not affect body size limits at other layers of the application stack, so limits enforced in the WAF, gateway, or at the platform level are unaffected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2crg-3p73-43xp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2crg-3p73-43xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40073

Advisory: @sveltejs/adapter-node has a BODY_SIZE_LIMIT bypass
IDs: CVE-2026-40073, GHSA-2crg-3p73-43xp
Record: https://patchnext.com/advisories/cve-2026-40073 (revision 3, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 2.57.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sveltejs/kit: affected <= 2.57.0; fixed in 2.57.1

## Suggested inspection (read-only)
- `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sveltejs/kit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2crg-3p73-43xp (OSV record GHSA-2crg-3p73-43xp lists affected ranges: npm @sveltejs/kit >=0 <2.57.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2crg-3p73-43xp (GitHub-reviewed advisory GHSA-2crg-3p73-43xp lists affected ranges: npm @sveltejs/kit >=0 <=2.57.0)

Commands are suggestions: review each one before running it.

Loading voting…