Skip to content

← Actionable
High, CVSS 8.1

bsv-sdk and bsv-wallet persist unverified certifier signatures in acquire_certificate (direct and issuance paths)

CVE-2026-40070GHSA-hc36-c89j-5f4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bsv-wallet 0.3.4; bsv-sdk 0.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems bsv-wallet

    Affected
    >= 0.1.2, < 0.3.4
    Fixed in
    0.3.4
  • RubyGems bsv-sdk

    Affected
    >= 0.3.1, < 0.8.2
    Fixed in
    0.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-40070: 0.14% estimated exploitation activity in the next 30 days; percentile 3.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unverified certifier signatures persisted by acquirecertificate Affected packages Both bsv-sdk and bsv-wallet are published from the sgbett/bsv-ruby-sdk repository. The vulnerable code lives in lib/bsv/walletinterface/walletclient.rb, which is physically shipped inside both gems (the bsv-wallet.gemspec files list bundles the entire lib/bsv/walletinterface/ tree). Consumers of either gem are independently vulnerable; the two packages are versioned separately, so each has its own affected range. | Package | Affected | Patched | | --- | --- | --- | | bsv-sdk | = 0.3.1, < 0.8.2 | 0.8.2 | | bsv-wallet | = 0.1.2, < 0.3.4 | 0.3.4 | Summary BSV::Wallet::WalletClient#acquirecertificate persists certificate records to storage without verifying the certifier's signature over the certificate contents. Both acquisition paths are affected: - acquisitionprotocol: 'direct' — the caller supplies all certificate fields (including signature:) and the record is written to storage verbatim. -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hc36-c89j-5f4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40070

Advisory: bsv-sdk and bsv-wallet persist unverified certifier signatures in acquire_certificate (direct and issuance paths)
IDs: CVE-2026-40070, GHSA-hc36-c89j-5f4j
Record: https://patchnext.com/advisories/cve-2026-40070 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bsv-wallet 0.3.4; bsv-sdk 0.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems bsv-wallet: affected >= 0.1.2, < 0.3.4; fixed in 0.3.4
- RubyGems bsv-sdk: affected >= 0.3.1, < 0.8.2; fixed in 0.8.2

## Suggested inspection (read-only)
- RubyGems bsv-wallet: check the installed version with your package manager.
- RubyGems bsv-sdk: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bsv-wallet, bsv-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hc36-c89j-5f4j (GitHub-reviewed advisory GHSA-hc36-c89j-5f4j lists affected ranges: RubyGems bsv-sdk >=0.3.1 =0.1.2 <0.3.4)

Commands are suggestions: review each one before running it.

Loading voting…