Skip to content

← Actionable
High, CVSS 7.8amended

Camel-PQC Vulnerable to Deserialization of Untrusted Data

CVE-2026-40048GHSA-v3vg-332r-mw99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-pqc 4.20.0, 4.18.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-40048: 0.33% estimated exploitation activity in the next 30 days; percentile 25.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Camel-PQC FileBasedKeyLifecycleManager class deserializes the contents of ` .key` files in the configured key directory using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. The cast to `java.security.KeyPair` is evaluated only after `readObject()` has already returned, so any `readObject()` side effects in the deserialized object run before the type check. An attacker who can write to the key directory used by a Camel application — for example through a path traversal into the directory, misconfigured filesystem permissions on the volume where keys are stored, a compromised key provisioning pipeline, or a symlink attack — can place a crafted serialized Java object that, when deserialized during normal key lifecycle operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.19.0 before 4.20.0, from 4.18.0 before 4.18.2. Users are recommended to upgrade to version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-v3vg-332r-mw99

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-v3vg-332r-mw99

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v3vg-332r-mw99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40048

Advisory: Camel-PQC Vulnerable to Deserialization of Untrusted Data
IDs: CVE-2026-40048, GHSA-v3vg-332r-mw99
Record: https://patchnext.com/advisories/cve-2026-40048 (revision 3, source checked 4 Nov 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-pqc 4.20.0, 4.18.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-pqc: affected < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.20.0

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-pqc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-pqc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v3vg-332r-mw99 (GitHub-reviewed advisory GHSA-v3vg-332r-mw99 lists affected ranges: Maven org.apache.camel:camel-pqc >=0 <4.18.2)
- Verified: https://github.com/advisories/GHSA-v3vg-332r-mw99 (GitHub-reviewed advisory GHSA-v3vg-332r-mw99 lists affected ranges: Maven org.apache.camel:camel-pqc >=0 =4.19.0 <=4.19.0)
- Verified: https://osv.dev/vulnerability/GHSA-v3vg-332r-mw99 (OSV record GHSA-v3vg-332r-mw99 lists affected ranges: Maven org.apache.camel:camel-pqc >=0 =4.19.0 <4.20.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…