Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound
CVE-2026-40046GHSA-xvqc-pp94-fmpx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-mqtt 6.2.4; org.apache.activemq:apache-activemq 6.2.4; org.apache.activemq:activemq-all 6.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-mqtt
- Affected
- >= 6.0.0, < 6.2.4
- Fixed in
- 6.2.4
Maven org.apache.activemq:apache-activemq
- Affected
- >= 6.0.0, < 6.2.4
- Fixed in
- 6.2.4
Maven org.apache.activemq:activemq-all
- Affected
- >= 6.0.0, < 6.2.4
- Fixed in
- 6.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xvqc-pp94-fmpx lists affected ranges: Maven org.apache.activemq:apache-activemq >=6.0.0 =6.0.0 =6.0.0 <6.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-40046: 0.38% estimated exploitation activity in the next 30 days; percentile 31.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xvqc-pp94-fmpx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40046 Advisory: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound IDs: CVE-2026-40046, GHSA-xvqc-pp94-fmpx Record: https://patchnext.com/advisories/cve-2026-40046 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-mqtt 6.2.4; org.apache.activemq:apache-activemq 6.2.4; org.apache.activemq:activemq-all 6.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-mqtt: affected >= 6.0.0, < 6.2.4; fixed in 6.2.4 - Maven org.apache.activemq:apache-activemq: affected >= 6.0.0, < 6.2.4; fixed in 6.2.4 - Maven org.apache.activemq:activemq-all: affected >= 6.0.0, < 6.2.4; fixed in 6.2.4 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-mqtt: check the installed version with your package manager. - Maven org.apache.activemq:apache-activemq: check the installed version with your package manager. - Maven org.apache.activemq:activemq-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-mqtt, org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xvqc-pp94-fmpx (GitHub-reviewed advisory GHSA-xvqc-pp94-fmpx lists affected ranges: Maven org.apache.activemq:apache-activemq >=6.0.0 =6.0.0 =6.0.0 <6.2.4) Commands are suggestions: review each one before running it.
Loading voting…