Skip to content

← Actionable
Critical, CVSS 9.3Exploited · CISA KEVamended

Marimo: Pre-Auth Remote Code Execution via Terminal WebSocket Authentication Bypass

CVE-2026-39987GHSA-2679-6mx9-h9xc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (marimo 0.23.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI marimo

    Affected
    < 0.23.0
    Fixed in
    0.23.0

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-39987: 99.74% estimated exploitation activity in the next 30 days; percentile 99.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Marimo (19.6k stars) has a Pre-Auth RCE vulnerability. The terminal WebSocket endpoint /terminal/ws lacks authentication validation, allowing an unauthenticated attacker to obtain a full PTY shell and execute arbitrary system commands. Unlike other WebSocket endpoints (e.g., /ws) that correctly call validateauth() for authentication, the /terminal/ws endpoint only checks the running mode and platform support before accepting connections, completely skipping authentication verification. Affected Versions Marimo <= 0.20.4 Vulnerability Details Root Cause: Terminal WebSocket Missing Authentication marimo/server/api/endpoints/terminal.py lines 340-356: Compare with the correctly implemented /ws endpoint (wsendpoint.py lines 67-82): Authentication Middleware Limitation Marimo uses Starlette's AuthenticationMiddleware, which marks failed auth connections as UnauthenticatedUser but does NOT actively reject WebSocket connections. Actual auth enforcement relies on endpoint-level…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-2679-6mx9-h9xc

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-2679-6mx9-h9xc

  4. Revision 1 · created ·

    Published from ghsa record GHSA-2679-6mx9-h9xc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39987

Advisory: Marimo: Pre-Auth Remote Code Execution via Terminal WebSocket Authentication Bypass
IDs: CVE-2026-39987, GHSA-2679-6mx9-h9xc
Record: https://patchnext.com/advisories/cve-2026-39987 (revision 4, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: marimo 0.23.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI marimo: affected < 0.23.0; fixed in 0.23.0

## Suggested inspection (read-only)
- `python -m pip show marimo`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on marimo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-39987 to the Known Exploited Vulnerabilities catalog on 2026-04-23.)
- Verified: https://github.com/advisories/GHSA-2679-6mx9-h9xc (GitHub-reviewed advisory GHSA-2679-6mx9-h9xc lists affected ranges: PyPI marimo >=0 <0.23.0)
- Verified: https://osv.dev/vulnerability/GHSA-2679-6mx9-h9xc (OSV record GHSA-2679-6mx9-h9xc lists affected ranges: PyPI marimo >=0 <0.23.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…