Skip to content

← Actionable
High, CVSS 7.1

Laravel Passport: TokenGuard Authenticates Unrelated User for Client Credentials Tokens

CVE-2026-39976GHSA-349c-2h2f-mxf6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/passport 13.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-39976: 0.29% estimated exploitation activity in the next 30 days; percentile 21.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Authentication Bypass for clientcredentials tokens. the league/oauth2-server library sets the JWT sub claim to the client identifier (since there's no user). The token guard then passes this value to retrieveById() without validating it's actually a user identifier, potentially resolving an unrelated real user. Any machine-to-machine token can inadvertently authenticate as an actual user. Usage of EnsureClientIsResourceOwner middleware together with Passport::$clientUuids set to false, can result in resolving the user instead, as stated in the documentation. The underlying OAuth2 server sets the token's sub claim to the client's identifier for client credentials tokens. By default, Passport uses UUIDs for clients, so this cannot collide with a user's integer primary key. However, if you have set Passport::$clientUuids to false, a client credentials token may inadvertently resolve a user whose ID matches the client's ID. In such cases, using this middleware cannot guarantee…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-349c-2h2f-mxf6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39976

Advisory: Laravel Passport: TokenGuard Authenticates Unrelated User for Client Credentials Tokens
IDs: CVE-2026-39976, GHSA-349c-2h2f-mxf6
Record: https://patchnext.com/advisories/cve-2026-39976 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/passport 13.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/passport: affected >= 13.0.0, < 13.7.1; fixed in 13.7.1

## Suggested inspection (read-only)
- Packagist laravel/passport: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/passport.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-349c-2h2f-mxf6 (GitHub-reviewed advisory GHSA-349c-2h2f-mxf6 lists affected ranges: Packagist laravel/passport >=13.0.0 <13.7.1)

Commands are suggestions: review each one before running it.

Loading voting…