Skip to content

← Actionable
High, CVSS 8.5amended

n8n-mcp has authenticated SSRF via instance-URL header in multi-tenant HTTP mode

CVE-2026-39974GHSA-4ggg-h7ph-26qr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.47.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    <= 2.47.3
    Fixed in
    2.47.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-39974: 0.32% estimated exploitation activity in the next 30 days; percentile 24.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated Server-Side Request Forgery in n8n-mcp allows a caller holding a valid AUTHTOKEN to cause the server to issue HTTP requests to arbitrary URLs supplied through multi-tenant HTTP headers. Response bodies are reflected back through JSON-RPC, so an attacker can read the contents of any URL the server can reach — including cloud instance metadata endpoints (AWS IMDS, GCP, Azure, Alibaba, Oracle), internal network services, and any other host the server process has network access to. The primary at-risk deployments are multi-tenant HTTP installations where more than one operator can present a valid AUTHTOKEN, or where a token is shared with less-trusted clients. Single-tenant stdio deployments and HTTP deployments without multi-tenant headers are not affected. Affected versions n8n-mcp ≤ 2.47.3 (all versions up to and including 2.47.3). Patched versions n8n-mcp 2.47.4 and later. Workarounds If you cannot immediately upgrade: 1. Egress filtering at the network layer…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4ggg-h7ph-26qr

  2. Revision 1 · created ·

    Published from osv record GHSA-4ggg-h7ph-26qr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39974

Advisory: n8n-mcp has authenticated SSRF via instance-URL header in multi-tenant HTTP mode
IDs: CVE-2026-39974, GHSA-4ggg-h7ph-26qr
Record: https://patchnext.com/advisories/cve-2026-39974 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.47.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected <= 2.47.3; fixed in 2.47.4

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4ggg-h7ph-26qr (OSV record GHSA-4ggg-h7ph-26qr lists affected ranges: npm n8n-mcp >=0 <2.47.4 (fixed))
- Verified: https://github.com/advisories/GHSA-4ggg-h7ph-26qr (GitHub-reviewed advisory GHSA-4ggg-h7ph-26qr lists affected ranges: npm n8n-mcp >=0 <=2.47.3)

Commands are suggestions: review each one before running it.

Loading voting…