Directus: Sensitive fields exposed in revision history
CVE-2026-39943GHSA-mvv8-v4jj-g47j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 11.17.0
- Fixed in
- 11.17.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mvv8-v4jj-g47j lists affected ranges: npm directus >=0 <11.17.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mvv8-v4jj-g47j lists affected ranges: npm directus >=0 <11.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-39943: 0.17% estimated exploitation activity in the next 30 days; percentile 6.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Directus stores revision records (in directusrevisions) whenever items are created or updated. Due to the revision snapshot code not consistently calling the prepareDelta sanitization pipeline, sensitive fields (including user tokens, two-factor authentication secrets, external auth identifiers, auth data, stored credentials, and AI provider API keys) could be stored in plaintext within revision records. Impact Any user or service account with read access to directusrevisions (or flow logs) could retrieve values for fields that are supposed to be concealed or encrypted at rest, including: - token, tfasecret, externalidentifier, authdata, credentials - aiopenaiapikey, aianthropicapikey, aigoogleapikey, aiopenaicompatibleapikey This could lead to account takeover (via stolen tokens or 2FA secrets) or unauthorized use of third-party API keys stored against users. Affected code paths 1. Item create/update revisions The data (snapshot) field written to directusrevisions was not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mvv8-v4jj-g47j
- Revision 1 · created ·
Published from osv record GHSA-mvv8-v4jj-g47j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39943 Advisory: Directus: Sensitive fields exposed in revision history IDs: CVE-2026-39943, GHSA-mvv8-v4jj-g47j Record: https://patchnext.com/advisories/cve-2026-39943 (revision 2, source checked 26 Oct 2026, 12:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 11.17.0; fixed in 11.17.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mvv8-v4jj-g47j (OSV record GHSA-mvv8-v4jj-g47j lists affected ranges: npm directus >=0 <11.17.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mvv8-v4jj-g47j (GitHub-reviewed advisory GHSA-mvv8-v4jj-g47j lists affected ranges: npm directus >=0 <11.17.0) Commands are suggestions: review each one before running it.
Loading voting…