Skip to content

← Actionable
Medium, CVSS 5.3amended

GeoNode contains a server-side request forgery vulnerability in the service registration endpoint

CVE-2026-39922GHSA-hw9r-6m78-w6h3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (geonode 5.0.2, 4.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI geonode

    Affected
    >= 4.0.0, < 4.4.5>= 5.0.0, < 5.0.2
    Fixed in
    4.4.5, 5.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-39922: 0.17% estimated exploitation activity in the next 30 days; percentile 6.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hw9r-6m78-w6h3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hw9r-6m78-w6h3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39922

Advisory: GeoNode contains a server-side request forgery vulnerability in the service registration endpoint
IDs: CVE-2026-39922, GHSA-hw9r-6m78-w6h3
Record: https://patchnext.com/advisories/cve-2026-39922 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: geonode 5.0.2, 4.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI geonode: affected >= 4.0.0, < 4.4.5; >= 5.0.0, < 5.0.2; fixed in 4.4.5, 5.0.2

## Suggested inspection (read-only)
- `python -m pip show geonode`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on geonode.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hw9r-6m78-w6h3 (OSV record GHSA-hw9r-6m78-w6h3 lists affected ranges: PyPI geonode >=4.0.0 =5.0.0 <5.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-hw9r-6m78-w6h3 (GitHub-reviewed advisory GHSA-hw9r-6m78-w6h3 lists affected ranges: PyPI geonode >=4.0.0 =5.0.0 <5.0.2)

Commands are suggestions: review each one before running it.

Loading voting…