Cryptography vulnerable to buffer overflow if non-contiguous buffers were passed to APIs
CVE-2026-39892GHSA-p423-j2cm-9vmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 46.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cryptography
- Affected
- >= 45.0.0, < 46.0.7
- Fixed in
- 46.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p423-j2cm-9vmq lists affected ranges: PyPI cryptography >=45.0.0 <46.0.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p423-j2cm-9vmq lists affected ranges: PyPI cryptography >=45.0.0 <46.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-39892: 0.65% estimated exploitation activity in the next 30 days; percentile 51.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. `Hash.update()`), this could lead to buffer overflows. For example: ```python h = Hash(SHA256()) b.update(buf[::-1]) ``` would read past the end of the buffer on Python >3.11
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-p423-j2cm-9vmq
- Revision 4 · amended ·
Amended from ghsa record GHSA-p423-j2cm-9vmq
- Revision 3 · amended ·
Amended from ghsa record GHSA-p423-j2cm-9vmq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p423-j2cm-9vmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39892 Advisory: Cryptography vulnerable to buffer overflow if non-contiguous buffers were passed to APIs IDs: CVE-2026-39892, GHSA-p423-j2cm-9vmq Record: https://patchnext.com/advisories/cve-2026-39892 (revision 5, source checked 4 Nov 2026, 06:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cryptography 46.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cryptography: affected >= 45.0.0, < 46.0.7; fixed in 46.0.7 ## Suggested inspection (read-only) - `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cryptography. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p423-j2cm-9vmq (OSV record GHSA-p423-j2cm-9vmq lists affected ranges: PyPI cryptography >=45.0.0 <46.0.7 (fixed)) - Verified: https://github.com/advisories/GHSA-p423-j2cm-9vmq (GitHub-reviewed advisory GHSA-p423-j2cm-9vmq lists affected ranges: PyPI cryptography >=45.0.0 <46.0.7) Commands are suggestions: review each one before running it.
Loading voting…