SGLangs replay_request_dump.py contains an insecure pickle.load() without validation and proper deserialization
CVE-2026-3989GHSA-hvwj-8w5g-28rg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sglang 0.5.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sglang
- Affected
- <= 0.5.9
- Fixed in
- 0.5.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hvwj-8w5g-28rg lists affected ranges: PyPI sglang >=0 <0.5.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hvwj-8w5g-28rg lists affected ranges: PyPI sglang >=0 <=0.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-3989: 0.49% estimated exploitation activity in the next 30 days; percentile 41.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SGLangs replayrequestdump.py contains an insecure pickle.load() without validation and proper deserialization. An attacker can take advantage of this by providing a malicious .pkl file, which will execute the attackers code on the device running the script.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hvwj-8w5g-28rg
- Revision 1 · created ·
Published from osv record GHSA-hvwj-8w5g-28rg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-3989 Advisory: SGLangs `replay_request_dump.py` contains an insecure pickle.load() without validation and proper deserialization IDs: CVE-2026-3989, GHSA-hvwj-8w5g-28rg Record: https://patchnext.com/advisories/cve-2026-3989 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sglang 0.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sglang: affected <= 0.5.9; fixed in 0.5.10 ## Suggested inspection (read-only) - `python -m pip show sglang`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sglang. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hvwj-8w5g-28rg (OSV record GHSA-hvwj-8w5g-28rg lists affected ranges: PyPI sglang >=0 <0.5.10 (fixed)) - Verified: https://github.com/advisories/GHSA-hvwj-8w5g-28rg (GitHub-reviewed advisory GHSA-hvwj-8w5g-28rg lists affected ranges: PyPI sglang >=0 <=0.5.9) Commands are suggestions: review each one before running it.
Loading voting…