Skip to content

← Actionable
Critical, CVSS 9.9amended

PraisonAI has sandbox escape via exception frame traversal in execute_code (subprocess mode)

CVE-2026-39888GHSA-qf73-2hrx-xprp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.5.115), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-39888: 0.48% estimated exploitation activity in the next 30 days; percentile 41.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary executecode() in praisonaiagents.tools.pythontools defaults to sandboxmode="sandbox", which runs user code in a subprocess wrapped with a restricted builtins dict and an AST-based blocklist. The AST blocklist embedded inside the subprocess wrapper (blockedattrs, line 143 of pythontools.py) contains only 11 attribute names — a strict subset of the 30+ names blocked in the direct-execution path. The four attributes that form a frame-traversal chain out of the sandbox are all absent from the subprocess list: | Attribute | In subprocess blockedattrs | In direct-mode blockedattrs | |---|---|---| | traceback | NO | YES | | tbframe | NO | YES | | fback | NO | YES | | fbuiltins | NO | YES | Chaining these attributes through a caught exception exposes the real Python builtins dict of the subprocess wrapper frame, from which exec can be retrieved and called under a non-blocked variable name — bypassing every remaining security layer. Tested and confirmed on praisonaiagents 1.5.113…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qf73-2hrx-xprp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qf73-2hrx-xprp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qf73-2hrx-xprp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39888

Advisory: PraisonAI has sandbox escape via exception frame traversal in `execute_code` (subprocess mode)
IDs: CVE-2026-39888, GHSA-qf73-2hrx-xprp
Record: https://patchnext.com/advisories/cve-2026-39888 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.5.115. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.5.114; fixed in 1.5.115

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qf73-2hrx-xprp (GitHub-reviewed advisory GHSA-qf73-2hrx-xprp lists affected ranges: PyPI praisonaiagents >=0 <=1.5.114)
- Verified: https://osv.dev/vulnerability/GHSA-qf73-2hrx-xprp (OSV record GHSA-qf73-2hrx-xprp lists affected ranges: PyPI praisonaiagents >=0 <1.5.115 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…