Skip to content

← Actionable
High, CVSS 8.3amended

MCP Server Kubernetes has an Argument Injection in port_forward tool via space-splitting

CVE-2026-39884GHSA-4xqg-gf5c-ghwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-kubernetes 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-39884: 0.26% estimated exploitation activity in the next 30 days; percentile 17.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The portforward tool in mcp-server-kubernetes constructs a kubectl command as a string and splits it on spaces before passing to spawn(). Unlike all other tools in the codebase which correctly use execFileSync("kubectl", argsArray), portforward uses string concatenation with user-controlled input (namespace, resourceType, resourceName, localPort, targetPort) followed by naive .split(" ") parsing. This allows an attacker to inject arbitrary kubectl flags by embedding spaces in any of these fields. Affected Versions <= 3.4.0 Vulnerability Details File: src/tools/portforward.ts (compiled: dist/tools/portforward.js) The startPortForward function builds a kubectl command string by concatenating user-controlled input: This string is then split on spaces and passed to spawn(): Because .split(" ") treats every space as an argument boundary, an attacker can inject additional kubectl flags by embedding spaces in any of the user-controlled fields. Contrast with other tools Every other…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4xqg-gf5c-ghwq

  2. Revision 1 · created ·

    Published from osv record GHSA-4xqg-gf5c-ghwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39884

Advisory: MCP Server Kubernetes has an Argument Injection in port_forward tool via space-splitting
IDs: CVE-2026-39884, GHSA-4xqg-gf5c-ghwq
Record: https://patchnext.com/advisories/cve-2026-39884 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-server-kubernetes 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mcp-server-kubernetes: affected <= 3.4.0; fixed in 3.5.0

## Suggested inspection (read-only)
- `npm ls mcp-server-kubernetes --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-server-kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4xqg-gf5c-ghwq (OSV record GHSA-4xqg-gf5c-ghwq lists affected ranges: npm mcp-server-kubernetes >=0 <3.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4xqg-gf5c-ghwq (GitHub-reviewed advisory GHSA-4xqg-gf5c-ghwq lists affected ranges: npm mcp-server-kubernetes >=0 <=3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…