Skip to content

← Actionable
Medium, CVSS 5.3amended

ApostropheCMS: Information Disclosure via choices/counts Query Parameters Bypassing publicApiProjection Field Restrictions

CVE-2026-39857GHSA-c276-fj82-f2pq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.29.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-39857: 0.43% estimated exploitation activity in the next 30 days; percentile 37.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The choices and counts query parameters in the Apostrophe CMS REST API allow unauthenticated users to extract distinct field values for any schema field that has a registered query builder, completely bypassing publicApiProjection restrictions that are intended to limit which fields are exposed publicly. Fields protected by viewPermission are similarly exposed. Details When a piece type configures publicApiProjection to enable public API access while restricting visible fields, the restriction is enforced via a MongoDB projection on the main query (piece-type/index.js:1130-1134). However, the choices and counts query builders bypass this protection through a separate code path. The vulnerable flow: 1. getRestQuery at piece-type/index.js:1120 calls applyBuildersSafely(req.query) (line 1122), which processes query parameters including choices and counts since both have launder methods (doc-type/index.js:2627-2628 and 2675-2676). 2. The publicApiProjection is applied afterward…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c276-fj82-f2pq

  2. Revision 1 · created ·

    Published from osv record GHSA-c276-fj82-f2pq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39857

Advisory: ApostropheCMS: Information Disclosure via choices/counts Query Parameters Bypassing publicApiProjection Field Restrictions
IDs: CVE-2026-39857, GHSA-c276-fj82-f2pq
Record: https://patchnext.com/advisories/cve-2026-39857 (revision 2, source checked 26 Oct 2026, 12:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.29.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected <= 4.28.0; fixed in 4.29.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c276-fj82-f2pq (OSV record GHSA-c276-fj82-f2pq lists affected ranges: npm apostrophe >=0 <4.29.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c276-fj82-f2pq (GitHub-reviewed advisory GHSA-c276-fj82-f2pq lists affected ranges: npm apostrophe >=0 <=4.28.0)

Commands are suggestions: review each one before running it.

Loading voting…