Skip to content

← Actionable
High, CVSS 8.8

Quarkus has Authentication/Authorization bypasses

CVE-2026-39852GHSA-rc95-pcm8-65v9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.quarkus:quarkus-vertx-http 3.35.1.1, 3.33.1.1, 3.27.3.1, 3.20.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.quarkus:quarkus-vertx-http

    Affected
    < 3.20.6.1>= 3.21.0, < 3.27.3.1>= 3.30.0, < 3.33.1.1>= 3.34.0, < 3.35.1.1
    Fixed in
    3.35.1.1, 3.33.1.1, 3.27.3.1, 3.20.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-39852: 0.71% estimated exploitation activity in the next 30 days; percentile 53.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Quarkus version 3.32.4 is vulnerable to an authorization bypass issue (GHSL-2026-099), in which semicolons (matrix parameters) in HTTP requests can be used to bypass security constraints, potentially allowing unauthorized access to protected resources. Unauthenticated or lower-privileged users can bypass HTTP path-based authorization policies by appending a semicolon (;) and arbitrary text to the request URL. The vulnerability arises from a path-normalization inconsistency: Quarkus's security layer performs authorization checks on the raw URL path (which preserves matrix parameters), whereas RESTEasy Reactive's routing layer strips matrix parameters before matching endpoints. This allows requests like /api/admin;anything to bypass policies protecting /api/admin while still routing to the protected endpoint. Impact This issue may lead to Authentication/Authorization bypasses. Credits This issue was discovered with the GitHub Security Lab Taskflow Agent and manually verified by GHSL…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rc95-pcm8-65v9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39852

Advisory: Quarkus has Authentication/Authorization bypasses
IDs: CVE-2026-39852, GHSA-rc95-pcm8-65v9
Record: https://patchnext.com/advisories/cve-2026-39852 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.quarkus:quarkus-vertx-http 3.35.1.1, 3.33.1.1, 3.27.3.1, 3.20.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.quarkus:quarkus-vertx-http: affected < 3.20.6.1; >= 3.21.0, < 3.27.3.1; >= 3.30.0, < 3.33.1.1; >= 3.34.0, < 3.35.1.1; fixed in 3.35.1.1, 3.33.1.1, 3.27.3.1, 3.20.6.1

## Suggested inspection (read-only)
- Maven io.quarkus:quarkus-vertx-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.quarkus:quarkus-vertx-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rc95-pcm8-65v9 (GitHub-reviewed advisory GHSA-rc95-pcm8-65v9 lists affected ranges: Maven io.quarkus:quarkus-vertx-http >=0 =3.21.0 =3.30.0 =3.34.0 <3.35.1.1)

Commands are suggestions: review each one before running it.

Loading voting…