Skip to content

← Actionable
High, CVSS 7.5amended

Emmett has a path traversal in internal assets handler

CVE-2026-39847GHSA-pr46-2v3c-5356

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (emmett 2.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI emmett

    Affected
    >= 2.5.0, < 2.8.1
    Fixed in
    2.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-39847: 0.50% estimated exploitation activity in the next 30 days; percentile 42.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The RSGI static handler for Emmett's internal assets (/emmett paths) is vulnerable to path traversal attacks. An attacker can use ../ sequences (eg /emmett/../rsgi/handlers.py) to read arbitrary files outside the assets directory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pr46-2v3c-5356

  2. Revision 1 · created ·

    Published from osv record GHSA-pr46-2v3c-5356

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39847

Advisory: Emmett has a path traversal in internal assets handler
IDs: CVE-2026-39847, GHSA-pr46-2v3c-5356
Record: https://patchnext.com/advisories/cve-2026-39847 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: emmett 2.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI emmett: affected >= 2.5.0, < 2.8.1; fixed in 2.8.1

## Suggested inspection (read-only)
- `python -m pip show emmett`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on emmett.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pr46-2v3c-5356 (OSV record GHSA-pr46-2v3c-5356 lists affected ranges: PyPI emmett >=2.5.0 <2.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pr46-2v3c-5356 (GitHub-reviewed advisory GHSA-pr46-2v3c-5356 lists affected ranges: PyPI emmett >=2.5.0 <2.8.1)

Commands are suggestions: review each one before running it.

Loading voting…