Skip to content

← Actionable
Medium, CVSS 5.9amended

H2O-3 is Vulnerable to Code Injection

CVE-2026-3960GHSA-qmcv-hh7c-3m56

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (h2o 3.46.0.10; ai.h2o:h2o-core 3.46.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI h2o

    Affected
    < 3.46.0.10
    Fixed in
    3.46.0.10
  • Maven ai.h2o:h2o-core

    Affected
    < 3.46.0.10
    Fixed in
    3.46.0.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-3960: 0.94% estimated exploitation activity in the next 30 days; percentile 60.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A critical remote code execution vulnerability exists in the unauthenticated REST API endpoint /99/ImportSQLTable in H2O-3 version 3.46.0.9 and prior. The vulnerability arises due to insufficient security controls in the parameter blacklist mechanism, which only targets MySQL JDBC driver-specific dangerous parameters. An attacker can bypass these controls by switching the JDBC URL protocol to jdbc:postgresql: and exploiting PostgreSQL JDBC driver-specific parameters such as socketFactory and socketFactoryArg. This allows unauthenticated attackers to execute arbitrary code on the H2O-3 server with the privileges of the H2O-3 process. The issue is resolved in version 3.46.0.10.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qmcv-hh7c-3m56

  2. Revision 1 · created ·

    Published from osv record PYSEC-2026-2180

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-3960

Advisory: H2O-3 is Vulnerable to Code Injection
IDs: CVE-2026-3960, GHSA-qmcv-hh7c-3m56
Record: https://patchnext.com/advisories/cve-2026-3960 (revision 2, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: h2o 3.46.0.10; ai.h2o:h2o-core 3.46.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI h2o: affected < 3.46.0.10; fixed in 3.46.0.10
- Maven ai.h2o:h2o-core: affected < 3.46.0.10; fixed in 3.46.0.10

## Suggested inspection (read-only)
- `python -m pip show h2o`: prints the installed version. Run with the environment that serves production active.
- Maven ai.h2o:h2o-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on h2o, ai.h2o:h2o-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2026-2180 (OSV record PYSEC-2026-2180 lists affected ranges: PyPI h2o >=0 <3.46.0.10 (fixed))
- Verified: https://github.com/advisories/GHSA-qmcv-hh7c-3m56 (GitHub-reviewed advisory GHSA-qmcv-hh7c-3m56 lists affected ranges: Maven ai.h2o:h2o-core >=0 <3.46.0.10)

Commands are suggestions: review each one before running it.

Loading voting…