kcp's cache server is accessible without authentication or authorization checks
CVE-2026-39429GHSA-3j3q-wp9x-585p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kcp-dev/kcp 0.30.3, 0.29.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.30.0, < 0.30.3< 0.29.3
- Fixed in
- 0.30.3, 0.29.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3j3q-wp9x-585p lists affected ranges: Go github.com/kcp-dev/kcp >=0.30.0 =0 <0.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-39429: 0.44% estimated exploitation activity in the next 30 days; percentile 37.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The cache server is directly exposed by the root shard and has no authentication or authorization in place. This allows anyone who can access the root shard to read and write to the cache server. Details The cache server is routed in the pre-mux chain in the shard code. The preHandlerChainMux is handled before any authn/authz in the cache server: https://github.com/kcp-dev/kcp/blob/aaf93d59cbcd0cefb70d94bd8959ce390547c4a2/pkg/server/config.go#L514-L518 This results in the cache server being proxied before any authn/authz in the handler chain takes place. Attack Vectors 1. Unauthenticated Read Access (Primary) An attacker can read all replicated resources from the cache without any credentials. This exposes: | Category | Resources | Severity | Reason | |---|---|---|---| | RBAC | clusterroles, clusterrolebindings (filtered by annotation) | High | Only subset with internal.kcp.io/replicate annotation: access rules, APIExport bind/content rules, WorkspaceType use rules. Reveals…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3j3q-wp9x-585p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39429 Advisory: kcp's cache server is accessible without authentication or authorization checks IDs: CVE-2026-39429, GHSA-3j3q-wp9x-585p Record: https://patchnext.com/advisories/cve-2026-39429 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kcp-dev/kcp 0.30.3, 0.29.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kcp-dev/kcp: affected >= 0.30.0, < 0.30.3; < 0.29.3; fixed in 0.30.3, 0.29.3 ## Suggested inspection (read-only) - Go github.com/kcp-dev/kcp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kcp-dev/kcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3j3q-wp9x-585p (GitHub-reviewed advisory GHSA-3j3q-wp9x-585p lists affected ranges: Go github.com/kcp-dev/kcp >=0.30.0 =0 <0.29.3) Commands are suggestions: review each one before running it.
Loading voting…