lightrag-hku: JWT Algorithm Confusion Vulnerability
CVE-2026-39413GHSA-8ffj-4hx4-9pgf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightrag-hku 1.4.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lightrag-hku
- Affected
- <= 1.4.13
- Fixed in
- 1.4.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8ffj-4hx4-9pgf lists affected ranges: PyPI lightrag-hku >=0 <1.4.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8ffj-4hx4-9pgf lists affected ranges: PyPI lightrag-hku >=0 <=1.4.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-39413: 0.17% estimated exploitation activity in the next 30 days; percentile 6.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The LightRAG API is vulnerable to a JWT algorithm confusion attack where an attacker can forge tokens by specifying 'alg': 'none' in the JWT header. Since the jwt.decode() call does not explicitly deny the 'none' algorithm, a crafted token without a signature will be accepted as valid, leading to unauthorized access. Details In lightrag/api/auth.py at line 128, the validatetoken method calls: This allows any algorithm listed in the token's header to be processed, including 'none'. The code does not explicitly specify that 'none' is not allowed, making it possible for an attacker to bypass authentication. PoC An attacker can generate a JWT with the following structure: Then send a request like: Impact An attacker can impersonate any user, including administrators, by forging a JWT with 'alg': 'none', gaining full access to protected resources without needing valid credentials. Recommended Fix Explicitly specify allowed algorithms and exclude 'none'. Modify the validatetoken…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8ffj-4hx4-9pgf
- Revision 1 · created ·
Published from osv record GHSA-8ffj-4hx4-9pgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-39413 Advisory: lightrag-hku: JWT Algorithm Confusion Vulnerability IDs: CVE-2026-39413, GHSA-8ffj-4hx4-9pgf Record: https://patchnext.com/advisories/cve-2026-39413 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightrag-hku 1.4.14. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lightrag-hku: affected <= 1.4.13; fixed in 1.4.14 ## Suggested inspection (read-only) - `python -m pip show lightrag-hku`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightrag-hku. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8ffj-4hx4-9pgf (OSV record GHSA-8ffj-4hx4-9pgf lists affected ranges: PyPI lightrag-hku >=0 <1.4.14 (fixed)) - Verified: https://github.com/advisories/GHSA-8ffj-4hx4-9pgf (GitHub-reviewed advisory GHSA-8ffj-4hx4-9pgf lists affected ranges: PyPI lightrag-hku >=0 <=1.4.13) Commands are suggestions: review each one before running it.
Loading voting…