Skip to content

← Actionable
Medium, CVSS 5.0amended

LobeHub: Unauthenticated authentication bypass on webapi routes via forgeable X-lobe-chat-auth header

CVE-2026-39411GHSA-5mwj-v5jw-5c97

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/lobehub 2.1.48), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-39411: 0.13% estimated exploitation activity in the next 30 days; percentile 2.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The webapi authentication layer trusts a client-controlled X-lobe-chat-auth header that is only XOR-obfuscated, not signed or otherwise authenticated. Because the XOR key is hardcoded in the repository, an attacker can forge arbitrary auth payloads and bypass authentication on protected webapi routes. Affected routes include: - POST /webapi/chat/[provider] - GET /webapi/models/[provider] - POST /webapi/models/[provider]/pull - POST /webapi/create-image/comfyui Details The frontend creates X-lobe-chat-auth by XOR-obfuscating JSON with the static key LobeHub · LobeHub, and the backend reverses that operation and treats the decoded JSON as trusted authentication data. The backend then accepts any truthy apiKey field in that decoded payload as sufficient authentication. No real API key validation is performed in this path. As a result, an unauthenticated attacker can forge payloads such as: or and access webapi routes as an authenticated user. Confirmed PoC The following forged…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5mwj-v5jw-5c97

  2. Revision 1 · created ·

    Published from osv record GHSA-5mwj-v5jw-5c97

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39411

Advisory: LobeHub: Unauthenticated authentication bypass on `webapi` routes via forgeable `X-lobe-chat-auth` header
IDs: CVE-2026-39411, GHSA-5mwj-v5jw-5c97
Record: https://patchnext.com/advisories/cve-2026-39411 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @lobehub/lobehub 2.1.48. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @lobehub/lobehub: affected <= 2.1.47; fixed in 2.1.48

## Suggested inspection (read-only)
- `npm ls @lobehub/lobehub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @lobehub/lobehub.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5mwj-v5jw-5c97 (OSV record GHSA-5mwj-v5jw-5c97 lists affected ranges: npm @lobehub/lobehub >=0 <2.1.48 (fixed))
- Verified: https://github.com/advisories/GHSA-5mwj-v5jw-5c97 (GitHub-reviewed advisory GHSA-5mwj-v5jw-5c97 lists affected ranges: npm @lobehub/lobehub >=0 <=2.1.47)

Commands are suggestions: review each one before running it.

Loading voting…