Skip to content

← Actionable
Unratedamended

openclaw-claude-bridge: sandbox is not effective - --allowed-tools "" does not restrict available tools

CVE-2026-39398GHSA-7853-gqqm-vcwx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw-claude-bridge 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected openclaw-claude-bridge v1.1.0 Issue v1.1.0 spawns the Claude Code CLI subprocess with --allowed-tools "" and the release notes + README claim this "disables all CLI tools" for sandboxing. This claim is incorrect. Per the Claude Code CLI documentation, --allowed-tools (alias --allowedTools) is an auto-approve allowlist of tools that execute without permission prompts — NOT a restriction on which tools are available. The correct flag to restrict the available tool set is --tools: --tools <tools... Specify the list of available tools from the built-in set. Use "" to disable all tools, "default" to use all tools, or specify tool names (e.g. "Bash,Edit,Read"). Impact - All CLI tools (Read/Write/Bash/WebFetch/...) remain nominally available to the spawned subprocess. - Actual execution behavior in --print non-interactive mode depends on undocumented CLI defaults (may auto-deny, may error out, may hang). - Users who deploy the bridge behind any interface that forwards untrusted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7853-gqqm-vcwx

  2. Revision 1 · created ·

    Published from osv record GHSA-7853-gqqm-vcwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39398

Advisory: openclaw-claude-bridge: sandbox is not effective - `--allowed-tools ""` does not restrict available tools
IDs: CVE-2026-39398, GHSA-7853-gqqm-vcwx
Record: https://patchnext.com/advisories/cve-2026-39398 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw-claude-bridge 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw-claude-bridge: affected <= 1.1.1; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls openclaw-claude-bridge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw-claude-bridge.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7853-gqqm-vcwx (OSV record GHSA-7853-gqqm-vcwx lists affected ranges: npm openclaw-claude-bridge >=0 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7853-gqqm-vcwx (GitHub-reviewed advisory GHSA-7853-gqqm-vcwx lists affected ranges: npm openclaw-claude-bridge >=0 <=1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…