Skip to content

← Actionable
Critical, CVSS 9.4amended

@delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections

CVE-2026-39397GHSA-65w6-pf7x-5g85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@delmaredigital/payload-puck 0.6.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-39397: 0.38% estimated exploitation activity in the next 30 days; percentile 31.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All /api/puck/ CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. An unauthenticated remote attacker could: - List all documents (including drafts) in any Puck-registered collection - Read any document by ID (including drafts) - Create new documents with arbitrary field values - Update any document (including bypassing field-level access rules) - Delete any document - Read version history and restore arbitrary versions In typical installations, the affected scope is the collection backing the website's pages (default slug: pages). For most users this means an attacker could read, modify, create, or delete every page on the website — including unpublished drafts and version history. Scope is limited to collections…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-65w6-pf7x-5g85

  2. Revision 2 · amended ·

    Amended from osv record GHSA-65w6-pf7x-5g85

  3. Revision 1 · created ·

    Published from ghsa record GHSA-65w6-pf7x-5g85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39397

Advisory: @delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections
IDs: CVE-2026-39397, GHSA-65w6-pf7x-5g85
Record: https://patchnext.com/advisories/cve-2026-39397 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @delmaredigital/payload-puck 0.6.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @delmaredigital/payload-puck: affected < 0.6.23; fixed in 0.6.23

## Suggested inspection (read-only)
- `npm ls @delmaredigital/payload-puck --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @delmaredigital/payload-puck.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65w6-pf7x-5g85 (GitHub-reviewed advisory GHSA-65w6-pf7x-5g85 lists affected ranges: npm @delmaredigital/payload-puck >=0 <0.6.23)
- Verified: https://osv.dev/vulnerability/GHSA-65w6-pf7x-5g85 (OSV record GHSA-65w6-pf7x-5g85 lists affected ranges: npm @delmaredigital/payload-puck >=0 <0.6.23 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…