Skip to content

← Actionable
Medium, CVSS 4.8

CI4MS has stored XSS via Unescaped Blacklist Note in Admin User List

CVE-2026-39391GHSA-7cm9-v848-cfh2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-39391: 0.23% estimated exploitation activity in the next 30 days; percentile 13.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The blacklist (ban) note parameter in UserController::ajaxblackListpost() is stored in the database without sanitization and rendered into an HTML data-note attribute without escaping. An admin with blacklist privileges can inject arbitrary JavaScript that executes in the browser of any other admin who views the user management page. Details In modules/Users/Controllers/UserController.php, the ajaxblackListpost() method (line 344-362) accepts a note POST parameter with only a required validation rule: Shield's Bannable::ban() trait stores the message as-is: In the users() method (line 13-91), when building the DataTables response, the statusmessage is concatenated directly into HTML without escaping: The HTML string is returned as JSON (line 90) and DataTables renders it into the DOM. CSP is disabled ($CSPEnabled = false in App.php), and no SecureHeaders filter is applied. PoC Step 1 — Store XSS payload via ban endpoint: Expected response:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7cm9-v848-cfh2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39391

Advisory: CI4MS has stored XSS via Unescaped Blacklist Note in Admin User List
IDs: CVE-2026-39391, GHSA-7cm9-v848-cfh2
Record: https://patchnext.com/advisories/cve-2026-39391 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ci4-cms-erp/ci4ms: affected <= 0.31.3.0; fixed in 0.31.4.0

## Suggested inspection (read-only)
- Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ci4-cms-erp/ci4ms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7cm9-v848-cfh2 (GitHub-reviewed advisory GHSA-7cm9-v848-cfh2 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <=0.31.3.0)

Commands are suggestions: review each one before running it.

Loading voting…