Skip to content

← Actionable
Medium, CVSS 5.5

CI4MS has stored XSS via srcdoc attribute bypass in Google Maps iframe setting

CVE-2026-39390GHSA-x3hr-cp7x-44r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-39390: 0.24% estimated exploitation activity in the next 30 days; percentile 14.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Google Maps iframe setting (cMap field) in compInfosPost() sanitizes input using striptags() with an <iframe allowlist and regex-based removal of on\w+ event handlers. However, the srcdoc attribute is not an event handler and passes all filters. An attacker with admin settings access can inject an <iframe srcdoc="..." payload with HTML-entity-encoded JavaScript that executes in the context of the parent page when rendered to unauthenticated frontend visitors. Details Input sanitization (modules/Settings/Controllers/Settings.php:49-53): The three regex patterns only match attributes beginning with on (e.g., onclick, onerror). The srcdoc attribute does not begin with on and passes through untouched. Output rendering (app/Views/templates/default/gmapiframe.php:3): The output applies striptags with the same <iframe allowlist but performs no attribute filtering or HTML encoding. The stored payload is rendered verbatim. Why HTML entities bypass striptags: A payload like <iframe…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x3hr-cp7x-44r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39390

Advisory: CI4MS has stored XSS via srcdoc attribute bypass in Google Maps iframe setting
IDs: CVE-2026-39390, GHSA-x3hr-cp7x-44r2
Record: https://patchnext.com/advisories/cve-2026-39390 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ci4-cms-erp/ci4ms: affected <= 0.31.3.0; fixed in 0.31.4.0

## Suggested inspection (read-only)
- Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ci4-cms-erp/ci4ms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x3hr-cp7x-44r2 (GitHub-reviewed advisory GHSA-x3hr-cp7x-44r2 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <=0.31.3.0)

Commands are suggestions: review each one before running it.

Loading voting…