Skip to content

← Actionable
Medium, CVSS 6.7

CI4MS has a Hidden Items Authorization Bypass in Fileeditor Allows Reading Secrets and Writing Protected Files

CVE-2026-39389GHSA-9rxp-f27p-wv3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2026-39389: 0.47% estimated exploitation activity in the next 30 days; percentile 40.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Fileeditor controller defines a hiddenItems array containing security-sensitive paths (.env, composer.json, vendor/, .git/) but only enforces this protection in the listFiles() method. The readFile(), saveFile(), deleteFileOrFolder(), renameFile(), createFile(), and createFolder() endpoints perform no hidden items validation, allowing direct API access to files that are intended to be protected. A backend user with only fileeditor.read permission can exfiltrate application secrets from .env, and a user with fileeditor.update permission can overwrite composer.json to achieve remote code execution. Details The hiddenItems array is defined at modules/Fileeditor/Controllers/Fileeditor.php:10-26: This array is checked only in listFiles() at lines 45-48 and 64: However, readFile() (line 76) performs neither a hiddenItems check nor an allowedFileTypes() check: This means any file within ROOTPATH — regardless of extension (.php, .env, etc.) — can be read by any user with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9rxp-f27p-wv3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39389

Advisory: CI4MS has a Hidden Items Authorization Bypass in Fileeditor Allows Reading Secrets and Writing Protected Files
IDs: CVE-2026-39389, GHSA-9rxp-f27p-wv3h
Record: https://patchnext.com/advisories/cve-2026-39389 (revision 1, source checked 26 Oct 2026, 14:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ci4-cms-erp/ci4ms: affected <= 0.31.3.0; fixed in 0.31.4.0

## Suggested inspection (read-only)
- Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ci4-cms-erp/ci4ms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9rxp-f27p-wv3h (GitHub-reviewed advisory GHSA-9rxp-f27p-wv3h lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <=0.31.3.0)

Commands are suggestions: review each one before running it.

Loading voting…