Skip to content

← Actionable
High, CVSS 8.8

Neko has a Self-service Privilege Escalation for Authenticated Users

CVE-2026-39386GHSA-2gw9-c2r2-f5qf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/m1k1o/neko/server 3.0.11, 0.0.0-20260406184107-c54bcf1ee211), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/m1k1o/neko/server

    Affected
    >= 3.0.0, < 3.0.11>= 0.0.0-20250322225643-212bf8a60756, < 0.0.0-20260406184107-c54bcf1ee211
    Fixed in
    3.0.11, 0.0.0-20260406184107-c54bcf1ee211

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-2gw9-c2r2-f5qf lists affected ranges: Go github.com/m1k1o/neko/server >=3.0.0 =0.0.0-20250322225643-212bf8a60756 <0.0.0-20260406184107-c54bcf1ee211

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-39386: 0.44% estimated exploitation activity in the next 30 days; percentile 38.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any authenticated user can immediately obtain full administrative control of the entire Neko instance (member management, room settings, broadcast control, session termination, etc.). This results in a complete compromise of the instance. Patches The vulnerability has been patched in the following releases: - v3.0.11 (backport release) - v3.1.2 (latest stable release) Users should upgrade to v3.0.11 or later (for the 3.0 branch) or v3.1.2 or later. Workarounds If upgrading is not immediately possible, the following mitigations can reduce risk: - Restrict access to trusted users only (avoid granting accounts to untrusted parties) - Run the instance only when needed; avoid leaving it continuously exposed - Disable or restrict access to the /api/profile endpoint if feasible - Monitor for suspicious privilege changes or unexpected administrative actions Note: These are temporary mitigations and do not fully eliminate the vulnerability. Upgrading is strongly recommended. Credits…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2gw9-c2r2-f5qf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39386

Advisory: Neko has a Self-service Privilege Escalation for Authenticated Users
IDs: CVE-2026-39386, GHSA-2gw9-c2r2-f5qf
Record: https://patchnext.com/advisories/cve-2026-39386 (revision 1, source checked 26 Oct 2026, 15:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/m1k1o/neko/server 3.0.11, 0.0.0-20260406184107-c54bcf1ee211. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/m1k1o/neko/server: affected >= 3.0.0, < 3.0.11; >= 0.0.0-20250322225643-212bf8a60756, < 0.0.0-20260406184107-c54bcf1ee211; fixed in 3.0.11, 0.0.0-20260406184107-c54bcf1ee211

## Suggested inspection (read-only)
- Go github.com/m1k1o/neko/server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/m1k1o/neko/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2gw9-c2r2-f5qf (GitHub-reviewed advisory GHSA-2gw9-c2r2-f5qf lists affected ranges: Go github.com/m1k1o/neko/server >=3.0.0 =0.0.0-20250322225643-212bf8a60756 <0.0.0-20260406184107-c54bcf1ee211)

Commands are suggestions: review each one before running it.

Loading voting…