Skip to content

← Actionable
High, CVSS 7.5amended

FastFeedParser has an infinite redirect loop DoS via meta-refresh chain

CVE-2026-39376GHSA-4gx2-pc4f-wq37

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastfeedparser 0.5.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-39376: 0.33% estimated exploitation activity in the next 30 days; percentile 26.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When parse() fetches a URL that returns an HTML page containing a <meta http-equiv="refresh" tag, it recursively calls itself with the redirect URL — with no depth limit, no visited-URL deduplication, and no redirect count cap. An attacker-controlled server that returns an infinite chain of HTML meta-refresh responses causes unbounded recursion, exhausting the Python call stack and crashing the process. This vulnerability can also be chained with the companion SSRF issue to reach internal network targets after bypassing the initial URL check. Details parse() catches ValueError on XML parse failure, extracts a meta-refresh URL from the HTML response via extractmetarefreshurl(), and tail-calls itself with that URL. The recursive call is unconditional — there is no maximum redirect depth, no set of already-visited URLs, and no guard against self-referential or looping redirects. fastfeedparser/main.py — parse() (recursive sink): extractmetarefreshurl() uses urljoin(baseurl,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4gx2-pc4f-wq37

  2. Revision 1 · created ·

    Published from osv record GHSA-4gx2-pc4f-wq37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39376

Advisory: FastFeedParser has an infinite redirect loop DoS via meta-refresh chain
IDs: CVE-2026-39376, GHSA-4gx2-pc4f-wq37
Record: https://patchnext.com/advisories/cve-2026-39376 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastfeedparser 0.5.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastfeedparser: affected <= 0.5.9; fixed in 0.5.10

## Suggested inspection (read-only)
- `python -m pip show fastfeedparser`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastfeedparser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4gx2-pc4f-wq37 (OSV record GHSA-4gx2-pc4f-wq37 lists affected ranges: PyPI fastfeedparser >=0 <0.5.10 (fixed))
- Verified: https://github.com/advisories/GHSA-4gx2-pc4f-wq37 (GitHub-reviewed advisory GHSA-4gx2-pc4f-wq37 lists affected ranges: PyPI fastfeedparser >=0 <=0.5.9)

Commands are suggestions: review each one before running it.

Loading voting…