Skip to content

← Actionable
Medium, CVSS 5.3amended

JWCrypto: JWE ZIP decompression bomb

CVE-2026-39373GHSA-fjrm-76x2-c4q4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jwcrypto 1.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI jwcrypto

    Affected
    <= 1.5.6
    Fixed in
    1.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-39373: 0.29% estimated exploitation activity in the next 30 days; percentile 22.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fix for GHSA-j857-7rvv-vj97 in v1.5.6 is weak in that it does not allow to fully control the amount of plaintext the receiver is willing to deal with and provides just a weak upper bound. The patch limits input token size to 250KB but does not validate the decompressed output size. An unauthenticated attacker can craft a JWE token under the 250KB input limit that decompresses to very large data that may exceed small devices memory availability, causing Denial of Service via memory exhaustion. Although this is technically not unbounded I do recognize that it may be too much for devices and is something that could be surprising to developers, and we can do better than that. NOTE: the original report was sloppy (probably AI slop) and claimed arbitrary memory consumption, but simple testing showed that while 100MB could be decompressed a 1GB output was denied because the token exceeded the 250K compressed serialization. NOTE WELL: The proposed solution was also sloppy,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fjrm-76x2-c4q4

  2. Revision 1 · created ·

    Published from osv record GHSA-fjrm-76x2-c4q4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39373

Advisory: JWCrypto: JWE ZIP decompression bomb
IDs: CVE-2026-39373, GHSA-fjrm-76x2-c4q4
Record: https://patchnext.com/advisories/cve-2026-39373 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jwcrypto 1.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jwcrypto: affected <= 1.5.6; fixed in 1.5.7

## Suggested inspection (read-only)
- `python -m pip show jwcrypto`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jwcrypto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fjrm-76x2-c4q4 (OSV record GHSA-fjrm-76x2-c4q4 lists affected ranges: PyPI jwcrypto >=0 <1.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-fjrm-76x2-c4q4 (GitHub-reviewed advisory GHSA-fjrm-76x2-c4q4 lists affected ranges: PyPI jwcrypto >=0 <=1.5.6)

Commands are suggestions: review each one before running it.

Loading voting…