Skip to content

← Actionable
High, CVSS 8.1amended

RedwoodSDK has a CSRF vulnerability in server function dispatch via GET requests

CVE-2026-39371GHSA-x8rx-789c-2pxq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rwsdk 1.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm rwsdk

    Affected
    >= 1.0.0-beta.50, <= 1.0.5
    Fixed in
    1.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-39371: 0.21% estimated exploitation activity in the next 30 days; percentile 11.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Server functions exported from "use server" files could be invoked via GET requests, bypassing their intended HTTP method. In cookie-authenticated applications, this allowed cross-site GET navigations to trigger state-changing functions, because browsers send SameSite=Lax cookies on top-level GET requests. This affected all server functions -- both serverAction() handlers and bare exported functions in "use server" files. Impact An attacker could construct a URL containing a known action ID and JSON-encoded arguments. When a victim with an active session visited or was redirected to this URL, the function executed with the victim's credentials. This affected any server function that performs state-changing operations (writes, deletes, mutations) in applications using cookie-based authentication. Remediation Update to rwsdk 1.0.6. No application code changes are required. The fix enforces the declared HTTP method at dispatch time. GET requests to server functions that require…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x8rx-789c-2pxq

  2. Revision 1 · created ·

    Published from osv record GHSA-x8rx-789c-2pxq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-39371

Advisory: RedwoodSDK has a CSRF vulnerability in server function dispatch via GET requests
IDs: CVE-2026-39371, GHSA-x8rx-789c-2pxq
Record: https://patchnext.com/advisories/cve-2026-39371 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rwsdk 1.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm rwsdk: affected >= 1.0.0-beta.50, <= 1.0.5; fixed in 1.0.6

## Suggested inspection (read-only)
- `npm ls rwsdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rwsdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x8rx-789c-2pxq (OSV record GHSA-x8rx-789c-2pxq lists affected ranges: npm rwsdk >=1.0.0-beta.50 <1.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-x8rx-789c-2pxq (GitHub-reviewed advisory GHSA-x8rx-789c-2pxq lists affected ranges: npm rwsdk >=1.0.0-beta.50 <=1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…